Thursday, May 16, 2013

VPC configuration of Nexus Switches



VPC configuration of Nexus


Enable udld and lacp
NX_SW01(config)#feature udld

NX_SW01(config)#feature lacp
NX_SW01(config)# inter ethernet 1/3, ethernet 2/3    select ports
NX_SW01 (config-if-range)# description VPC Peer Link   vpc peer link
NX_SW01 (config-if-range)# switchport
NX_SW01 (config-if-range)# switchport mode trunk
NX_SW01 (config-if-range)# spanning-tree port type network
NX_SW01 (config-if-range)# rate-mode dedicated
NX_SW01 (config-if-range)# udld aggressive
NX_SW01 (config-if-range)# channel-group 1 mode active
NX_SW01 (config-if-range)# no shut
NX_SW01 (config-if-range)#exit
Secondary Switch
NX_SW02(config)#feature udld

NX_SW02(config)#feature lacp
Set up vpc peer link
NX_SW02(config)# inter ethernet 1/3, ethernet 2/3    select ports
NX_SW02 (config-if-range)# description VPC Peer Link   vpc peer link
NX_SW02 (config-if-range)# switchport
NX_SW02 (config-if-range)# switchport mode trunk
NX_SW02 (config-if-range)# spanning-tree port type network
NX_SW02 (config-if-range)# rate-mode dedicated
NX_SW02 (config-if-range)# udld aggressive
NX_SW02 (config-if-range)# channel-group 1 mode active
NX_SW02 (config-if-range)# no shut
NX_SW02(config-if-range)#exit

Primary SW01 as primary of even vlans
NX_SW01 (config)# spanning-tree vlan  200,202,204,206,208,210 root primary
NX-SW01 (config)# spanning-tree vlan 201,203,205,207,209,211 root secondary

SW02 as Primary for odd VLAN

NX-SW02 (config)# spanning-tree vlan 201,203,205,207,209,211 root primary
NX_SW02 (config)# spanning-tree vlan  200,202,204,206,208,210 root secondary
Primary switch
vpc domain 1
  peer-switch
  role priority 1024
  system-priority 4096   >>>> same in both primary and secondary switches
  peer-keepalive destination 10.10.10.2 source 10.10.10.1
delay restore 45
  peer-gateway
  auto-recovery
  ip arp synchronize
Secondary Switch
vpc domain 1
  peer-switch
  role priority 2048  >>higher number
  system-priority 4096 >>>> same in both primary and secondary switches
  peer-keepalive destination 10.10.10.1 source 10.10.10.1
  delay restore 45
  peer-gateway
  auto-recovery
  ip arp synchronize

Check the vpc status
Sh vpc br
Sh vpc peer-keepalive

Create port channel for peer link
Primary Sw01
Int po 1
Switchport
Switchport mode trunk
spanning-tree port type network
  vpc peer-link

Secondary Sw02

Int po 1
Switchport
Switchport mode trunk
spanning-tree port type network
  vpc peer-link
It is a good idea keep vpc peer link in different vrf
Create new vrf
NX_SW01 (config)# vrf context VPC_KEEPALIVE
NX_SW01 (config)# interface ethernet 1/3, ethernet 2/3
NX_SW01 (config-if-range)# channel-group 1 mode active
NX_SW01 (config-if-range)# udld enable
NX_SW01 (config-if-range)# description VPC Peer-keepalive link
NX_SW01 (config-if-range)# no shut

Nx_sw02
NX_SW02 (config)# vrf context VPC_KEEPALIVE
NX_SW02 (config)# interface ethernet 1/3, ethernet 2/3
NX_SW02 (config-if-range)# channel-group 1 mode active
NX_SW02 (config-if-range)# udld enable
NX_SW02 (config-if-range)# description VPC Peer-keepalive link
NX_SW02 (config-if-range)# no shut
NX_SW01 (config-if-range)# inter port 1
NX_SW01 (config-if)# vrf member VPC_KEEPALIVE
NX_SW01 (config-if)# ip address 10.10.10.1/30
NX_SW01 (config-if)# no shut
Nexus2 (config-if-range)# inter port 1
Nexus2 (config-if)# vrf member VPC_KEEPALIVE
Nexus2 (config-if)# ip address 10.10.10.2/30
Nexus2 (config-if)# no shut




Vlan conf
Vlan 20
  no ip redirects
  ip address x.x.x.x/24
  no ipv6 redirects
 
  hsrp version 2
  hsrp 0
        preempt delay minimum 90 reload 120
    priority 120
    timers msec 300 msec 900
    ip x.x.x.1

int po 20
switchport
switchport mode trunk
vpc 20

Trunk to another switch

interface port-channel19
  switchport
  switchport mode trunk
  vpc 19

interface Ethernet1/5
  switchport
  switchport mode trunk
  channel-group 19 mode active
  no shutdown

Trunk to Host Server like UCS

interface Ethernet1/8
  
  switchport mode trunk
  channel-group 31 mode active

interface port-channel31
    switchport mode trunk
  vpc 31

Access Port

interface port-channel 32
 
  vpc 32
  switchport access vlan 205
  spanning-tree port type edge

interface Ethernet1/32
  switchport access vlan 205
  channel-group 32 mode active

Secondary switch
interface port-channel32
  vpc 32
  switchport access vlan 205
  spanning-tree port type edge

interface Ethernet1/32
 
  switchport access vlan 205
  channel-group 32 mode active






Wednesday, May 15, 2013

Port Mirroring using Nexus



Port mirroring using Nexus


SW08# conf t

WS08(config)# no monitor session all

WS08(config)# interface e1/21   select the port#

WS08(config-if)# switchport monitor

WS08(config-if)# exit

WS08(config)# monitor session 2

WS08(config-monitor)# destination interface e 1/21

WS08(config-monitor)# exit

WS08(config)# monitor session 2

WS08(config-monitor)# source ?

  interface  Configure interfaces

  vlan       Vlan type

  vsan       Vsan type



WS08(config-monitor)# source vlan 90-91  select the source

WS08(config-monitor)# exit

WS08(config)# exit

WS08# sh monitor session 2

WS08(config-monitor)# ?

  description  Session description (max 32 characters)

  destination  Destination configuration

  no           Negate a command or set its defaults

  shut         Shut a monitor session

  source       Source configuration

  end          Go to exec mode

  exit         Exit from command interpreter

  pop          Pop mode from stack or restore from name

  push         Push current mode to stack or save it under name

  where        Shows the cli context you are in



WS08(config-monitor)# no shut

WS08(config-monitor)# exit

WS08(config)# exit

WS08# sh monitor session 2

   session 2

---------------

type              : local

state             : up

source intf       :

    rx            :

    tx            :

    both          :

source VLANs      :

    rx            : 90-91

source VSANs      :

    rx            :

destination ports : Eth1/21      




Monday, May 13, 2013

PRI VOICE configuration with MGCP Protocol




PRI VOICE configuration with MGCP Protocol


PRI interface configuration for a voice circuit with an assumption that the cable is located at slot #0 and port #2



network-clock-participate wic 0

network-clock-select 1 T1 0/2/0     >>>> clock priority

controller T1 0/2/0

 cablelength long 0db

 pri-group timeslots 1-24 service mgcp





interface Serial0/2/0:23

 no ip address

 encapsulation hdlc

 isdn switch-type primary-ni

 isdn incoming-voice voice

 isdn bind-l3 ccm-manager

 no cdp enable



RTR01#sh network

  Network Clock Configuration

  ---------------------------

  Priority      Clock Source    Clock State     Clock Type



     1          T1 0/2/0        GOOD            T1          primary

    10          Backplane       GOOD            PLL          backup



T1 0/2/0 is up.

  Applique type is Channelized T1

  Cablelength is long 0db

  No alarms detected.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info FPGA Rev: 08121917, FPGA Type: PRK4

  Framing is ESF, Line Code is B8ZS, Clock Source is Line.



         




Turn off pop notifications in chrome browser from major news outlets

 On Chrome browser, go to settings select privacy and security select site settings select Java Script Select Don't allow sites to use J...